Elevated API latency and rate limits

Incident Report for Sentry

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 09:48 UTC

Update

We are continuing to monitor the situation. While recovery is in progress, some users may experience intermittent issues accessing the user interface.
Posted Nov 14, 2025 - 09:20 UTC

Monitoring

A fix has been implemented and we're monitoring the results
Posted Nov 13, 2025 - 22:57 UTC

Investigating

We're investigating increased latency and 429 responses across our APIs
Posted Nov 13, 2025 - 22:18 UTC