Sentry.io Dashboard Failing to Load

Incident Report for Sentry

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 20:12 UTC

Update

Alert latency has resolved to nominal levels. We are still investigating the root cause of the incident.
Posted Aug 26, 2025 - 19:20 UTC

Update

Dashboard loading failures have subsided. We are still investigating downstream problems with alert execution latency.
Posted Aug 26, 2025 - 19:19 UTC

Update

We are continuing to investigate the issue.
Posted Aug 26, 2025 - 19:11 UTC

Investigating

We are currently investigating the issue.
Posted Aug 26, 2025 - 18:59 UTC