Increased Latency on Transactions in EU Region

Incident Report for Sentry

Resolved

The increased latency for transactions in our EU region has recovered.
Posted Aug 26, 2025 - 12:05 UTC

Identified

We have identified an issue causing latency of up to 10 minutes on transaction ingestion in our EU region and are working on a fix.
Posted Aug 26, 2025 - 11:45 UTC
This incident affected: EU Ingestion (EU Transaction Ingestion).