Delay in email notifications

Incident Report for Sentry

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 13:08 UTC

Identified

Email notifications related to issue workflow are currently delayed in the EU region
Posted Sep 13, 2025 - 12:52 UTC