Issues performance is degraded in the US

Incident Report for Sentry

Identified

We have identified a potential cause of excess traffic and are working on a fix.
Posted Aug 26, 2026 - 17:53 UTC

Investigating

We are experiencing slower page loads and API responses due to a database issue in us
Posted Aug 26, 2026 - 16:17 UTC
This incident affects: Dashboard and API.