Between 11:40 - 15:30 UTC, we experienced issues with elevated load and lock contention on the primary database in the US region leading to delays in data ingestion, alerting notifications, and webhook integrations. The database issue was caused by a long running REINDEX on the database in combination with elevated levels of traffic.
The issue was resolved and everything is operating as expected.
Posted Jul 21, 2025 - 16:31 UTC
Update
Everything looks good now, but we’re monitoring just in case.
Posted Jul 21, 2025 - 15:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2025 - 13:20 UTC
Update
We're continuing to investigate widespread delays in data ingestion, alerting, and integrations and will provide another update as soon as we've identified the root cause.
Posted Jul 21, 2025 - 13:03 UTC
Investigating
We are currently investigating this issue.
Posted Jul 21, 2025 - 12:07 UTC
This incident affected: US Ingestion (US Error Ingestion, US Transaction Ingestion, US Attachment Ingestion, US Span Ingestion), Alerting (US Errors Alerting, US Transactions Alerting, US Spans Alerting, US Uptime Monitoring), and Integration Pipeline.