Webhooks Delayed in US

Incident Report for Sentry

Resolved

Webhooks latency has returned to normal levels.
Posted Nov 05, 2025 - 22:03 UTC

Identified

Currently we are experiencing delays in webhook sending for custom integrations in the US region.
Posted Nov 05, 2025 - 19:00 UTC