Mail delivery delays in eu region.

Incident Report for Sentry

Resolved

Email delivery in the EU region is back to normal.
Posted Mar 17, 2025 - 17:10 UTC

Update

A mitigation has been put in place. We are continuing to monitor email delivery in the EU region for any further issues.
Posted Mar 17, 2025 - 15:40 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 17, 2025 - 12:52 UTC

Monitoring

Email delivery in the EU region is recovering.
Posted Mar 17, 2025 - 11:53 UTC

Identified

Our email provider in the EU region is having a partial outage, so email delivery will be temporarily inconsistent.
Posted Mar 17, 2025 - 11:03 UTC
This incident affected: Notification Delivery (Email).