Delayed ingestion on us region

Incident Report for Sentry

Resolved

We've burned through our spans backlog. Latency across span consumers are normal.
Posted Jul 21, 2026 - 14:14 UTC

Update

We're still burning through our spans backlog
Posted Jul 21, 2026 - 13:55 UTC

Monitoring

We've found and fixed the root cause and are burning through our spans backlog. Ingestion should be back to normal in around an hour.
Posted Jul 21, 2026 - 13:04 UTC

Update

We are still actively investigating this issue
Posted Jul 21, 2026 - 12:20 UTC

Update

We are still actively investigating this issue
Posted Jul 21, 2026 - 11:26 UTC

Investigating

We are actively investigating this issue
Posted Jul 21, 2026 - 10:30 UTC