Email notifications delays

Incident Report for Sentry

Resolved

This incident has been resolved.
Posted Aug 03, 2021 - 00:40 UTC

Identified

We have identified an issue with email notifications delivery, email are currently being delayed. We are working on fixing it.
Posted Aug 03, 2021 - 00:06 UTC
This incident affected: Notification Delivery (Email).