Ingestion and alerts for transactions delayed in EU region

Incident Report for Sentry

Resolved

Ingestion and alerting back to normal
Posted May 19, 2026 - 14:18 UTC

Monitoring

We've put in fixes and are monitoring the situation
Posted May 19, 2026 - 14:05 UTC