Sentry APIs experiencing High Latency

Incident Report for Sentry

Resolved

We have identified the issue and put a mitigation in place. API latency has returned to normal levels.
Posted Oct 24, 2025 - 17:37 UTC

Investigating

We are currently investigating elevated API latency in the US region.
Posted Oct 24, 2025 - 17:14 UTC