Subcription management page not working

Incident Report for Sentry

Resolved

Hot fix merged, all customers can access their subscription pages now.
Posted Apr 07, 2026 - 23:42 UTC

Monitoring

We are rolling out a fix
Posted Apr 07, 2026 - 22:28 UTC

Identified

We have identified an issue for customers trying to access their subscription page. we are working on a fix
Posted Apr 07, 2026 - 21:36 UTC