Higher than expected latency on sentry.io

Incident Report for Sentry

Resolved

Latency for sentry.io has returned to normal.
Posted May 22, 2026 - 08:23 UTC

Monitoring

We have implemented a fix and are monitoring.
Posted May 22, 2026 - 08:08 UTC

Investigating

We are currently investigating slow page loads on sentry.io.
Posted May 22, 2026 - 07:42 UTC