Degraded Issues Search Performance in the US region

Incident Report for Sentry

Resolved

This incident has been resolved
Posted Nov 18, 2025 - 03:53 UTC

Monitoring

We implemented a fix and are monitoring
Posted Nov 18, 2025 - 03:07 UTC

Investigating

We are currently investigating an issue in our infrastructure that is causing degraded search performance on the issues page
Posted Nov 17, 2025 - 21:58 UTC