The issue involving some alerts not firing has been mitigated. We will continue to monitor the situation to ensure it does not reoccur.
Posted Jun 11, 2026 - 14:18 UTC
Update
We have identified an issue with one of our cloud providers that might have caused some alert notifications to not fire starting at around 4:00 AM GMT+2.
Since around 1:30 PM GMT+2, alert notifications are now fully operational in the US region, while delivery is still partially degraded in the EU region.
Posted Jun 11, 2026 - 13:23 UTC
Monitoring
Notifications delivery is now close to fully functional in US and DE.
We have identified the root cause as caused by one of our cloud providers, and are closely monitoring the situation.
Posted Jun 11, 2026 - 13:13 UTC
Update
We are continuing to investigate the degraded notifications.
Posted Jun 11, 2026 - 11:51 UTC
Update
We are continuing to investigate the degraded notifications.
Posted Jun 11, 2026 - 10:53 UTC
Investigating
We're currently investigating degraded notification delivery.