Increased UI and API timeouts

Incident Report for Sentry

Update

We are continuing to investigate increased UI and API timeouts and errors
Posted May 12, 2026 - 13:51 UTC

Investigating

We are seeing increased UI and API timeouts and errors, due to an overloaded database cluster. Ingestion and alerting should not be affected.
Posted May 12, 2026 - 12:28 UTC