Delayed Notifications For Metric Based Alerts in US

Incident Report for Sentry

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 18:12 UTC

Update

Metric based alert notifications have returned to normal latency and we are continuing to monitor.
Posted Jul 24, 2025 - 18:01 UTC

Monitoring

Customers in the US region may have experienced delayed notifications for metric based alerts for up to 20 minutes, we have implemented a fix and the system is improving
Posted Jul 24, 2025 - 17:56 UTC