EU explore page performance degraded

Incident Report for Sentry

Resolved

The incident has been resolved
Posted Feb 09, 2026 - 19:39 UTC

Investigating

We are currently investigating
Posted Feb 09, 2026 - 19:33 UTC