Some alerts are delayed by 10-15 minutes.

Incident Report for Sentry

Resolved

We have identified and addressed the issue. Alerts are no longer delayed. Sorry for any inconvenience.
Posted May 09, 2023 - 18:57 UTC

Investigating

We are currently investigating the issue.
Posted May 09, 2023 - 18:18 UTC
This incident affected: Notification Delivery (Slack, Email, PagerDuty, Microsoft Teams).