Alerts delayed for US customers

Incident Report for Sentry

Resolved

Ingestion and alert latency is back to normal.
Posted Mar 09, 2026 - 20:37 UTC

Monitoring

We are burning the backlog and actively monitoring the progress.
Posted Mar 09, 2026 - 18:17 UTC

Identified

US customers may experience delay in alerts. We've identified the issue and will be putting in a fix.
Posted Mar 09, 2026 - 17:59 UTC