Email notifications for US region temporarily suspended

Incident Report for Sentry

Postmortem

On August 2, 2025 between 02:16 - 04:45 UTC, an unauthorized 3rd party obtained access to one of our email delivery accounts in our U.S. region which resulted in phishing emails being sent from noreply@sentry.io during that time frame.

Measures were taken to remove any unauthorized users as soon as it was detected and we can confirm email notifications are now operating normally. No Sentry customer service data or accounts were accessed by any unauthorized parties.

If you received any emails from noreply@sentry.io during the impacted time period, please ignore and delete them. Examples include emails with the following subject lines: 

  • “Transitioning All Assets to Self-Custody…”
  • “Security Update Following a Recent Incident…”.

If you have any questions, please reach out to us at support@sentry.io.

Posted Aug 05, 2025 - 18:58 UTC

Resolved

Between 02:16 - 04:45 UTC on Aug 2, we experienced an issue with email delivery in our US region. The issue was resolved and email notifications are operating as expected.
Posted Aug 02, 2025 - 05:19 UTC

Investigating

Email notifications for our U.S. data region are temporarily suspended as we investigate potential suspicious activity in our Sendgrid account.
Posted Aug 02, 2025 - 04:30 UTC
This incident affected: Notification Delivery (Email).