Degraded API response times

Incident Report for Sentry

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 00:06 UTC

Update

Fixes to improve latency have been applied, and additional improvements are being deployed.
Posted Apr 08, 2025 - 22:38 UTC

Investigating

We're investigating an issue causing increased latency for some users and working on a fix.
Posted Apr 08, 2025 - 19:25 UTC
This incident affected: API.