Intermittent dashboard failures & increased US ingest latency

Incident Report for Sentry

Resolved

Ingestion backlog has finished processing and our system is now operating normally.
Posted Feb 26, 2026 - 20:56 UTC

Monitoring

Our cloud provider has resolved an underlying problem and our dashboard availability issues have been resolved. We're continuing to process our ingestion backlog and monitor the situation.
Posted Feb 26, 2026 - 20:02 UTC

Investigating

We're investigating intermittent failures loading our dashboard (all regions) and increased latency for ingestion of all events types in US
Posted Feb 26, 2026 - 19:15 UTC