US Region Replay Ingestion Delays

Incident Report for Sentry

Resolved

The issue causing ingestion latency for replays in our US region has been resolved, and we have returned to normal operation.
Posted Jul 21, 2025 - 18:11 UTC

Monitoring

We have implemented a fix for the issue causing replay ingestion delays in our US region, and replay ingestion latency is now recovering. We will update here once things have returned to normal operation.
Posted Jul 21, 2025 - 17:49 UTC

Identified

We have identified an issue causing ingestion latency of up to 40 minutes on replays in our US region and are working on a fix.
Posted Jul 21, 2025 - 17:18 UTC
This incident affected: US Ingestion (US Replay Ingestion).