Error & Span processing delays in US

Incident Report for Sentry

Resolved

This incident has been resolved and backlogs have been processed.
Posted Apr 06, 2026 - 21:26 UTC

Monitoring

We have identified the source of postgres load and mitigated it. We are continuing to monitor conditions as backlogs process.
Posted Apr 06, 2026 - 20:52 UTC

Update

We are continuing to mitigate load in our postgres clusters.
Posted Apr 06, 2026 - 20:04 UTC

Update

We are continuing to mitigate load in our postgres clusters.
Posted Apr 06, 2026 - 19:04 UTC

Update

We're continuing to mitigate load in our caching and postgres infrastructure.
Posted Apr 06, 2026 - 18:26 UTC

Identified

We have identified the problem as a load issue in our caching layer and are working to mitigate the issue.
Posted Apr 06, 2026 - 17:11 UTC

Investigating

We are investigating processing delays for errors and spans in the US region
Posted Apr 06, 2026 - 15:56 UTC
This incident affected: US Ingestion (US Error Ingestion, US Span Ingestion).